Firefox 4: como añadir compatibilidad con las extensiones de Firefox 3.x

Firefox 4 logo

Desde hace un tiempo atrás ya está disponible la beta de Firefox 4, y como ha sucedido siempre con cada nueva versión mayor del navegador del zorrito, la mayoría de las extensiones dejan de funcionar debido a la falta de soporte. Algo que a estas alturas parece inconcebible, pero mientras esperamos que algún día Mozilla soporte la retrocompatibilidad, aquí presentamos tres formas de hacer que tus extensiones de Firefox 3.x funcionen en Firefox 4.0 beta.

La primera posibilidad es la de instalar una extensión llamada Compatibility Reporter, que automáticamente configura a Firefox 4 y las extensiones para que ambos sean compatibles entre sí y podamos utilizarlas. Una opción sin dudas sencilla e interesante, aunque no todo el mundo quiere instalar otra extensión ya que como sabemos, estas consumen algo de recursos.

Entonces hay que comenzar a meter mano, y la primera posibilidad es la de dirigirnos al about:config en Firefox, y una vez allí añadir una clave lógica o boolean, a la cual debemos nombrar como extensions.checkCompatibility.4.0.b, y luego establecer su valor en Falso. La tercera y última opción también implica meter mano, aunque en este caso lo que tendremos que hacer es descargar la extensión que deseamos instalar, descomprimirla y abrir el archivo install.rdf para modificar el valor de em:maxVersion a 4.0.*. Luego habrá que volver a empaquetarla y arrastrarla hacia el navegador.

Via Delicious (gracias SMaxPin)

Valora esta noticia: 1 estrella2 estrellas3 estrellas4 estrellas5 estrellas (0 votos, media: 0,00 de 5)
Loading ... Loading ...